(hdu1001)Sum Problem_JAVA_编程开发_程序员俱乐部

中国优秀的程序员网站程序员频道CXYCLUB技术地图
热搜:
更多>>
 
您所在的位置: 程序员俱乐部 > 编程开发 > JAVA > (hdu1001)Sum Problem

(hdu1001)Sum Problem

 2013/10/9 9:37:35  20131007  程序员俱乐部  我要评论(0)
  • 摘要:ProblemDescriptionHey,welcometoHDOJ(HangzhouDianziUniversityOnlineJudge).Inthisproblem,yourtaskistocalculateSUM(n)=1+2+3+...+n.InputTheinputwillconsistofaseriesofintegersn,oneintegerperline.OutputForeachcase,outputSUM(n)inoneline
  • 标签:
Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1

5050

class="java" name="code">import java.io.*;
import java.util.*;

public class Main
{
    public static void main(String args[])
    {
        Scanner cin = new Scanner(System.in);
        int n;

        while(cin.hasNextInt())
        {
            n = cin.nextInt();
            
            System.out.println(sum(n));
            System.out.println();
            
        }
    }
    
    public static int sum(int n) {
    	if(n % 2 == 0) {
    		return (n / 2) * (n + 1);
    	} else {
    		return ((n + 1) / 2) * n;
    	}
    }
}
  • 相关文章
发表评论
用户名: 匿名